vCard ImportExport FAQ

Does it work with latest Office, Windows?

All our software is updated to be compatible with latest Office and Windows versions.

Your system should comply with the following requirements:

  • Microsoft Office 2000, 2002 (XP), 2003, 2007, 2010, 2013, 2016 or 2019 installed.
  • Microsoft Windows 2000, XP, Vista, 7, 8, 8.1 or 10 installed. Both 32 and 64 bit versions are supported.
  • Administrator privileges for the installation.

Pages